Discussion regarding rifles chambered in 22 TCM
User avatar
By Carolina Shooter
#14588 At least a third of my rounds won't chamber in the rifle. Doesn't matter if reloads or factory ammo. Bolt become stuck and has to be driven to the rear to extract the round. Sometimes the round will chamber on a second attempt. Only have
about 50 rounds fired so far. Anyone have any suggestions? Please help.
User avatar
By dungheap
#14589 Look over a couple of years' worth of posts concerning problems people have had with the rifles, then send it in like most others did until you get one that works.

Sorry to rain on your parade, but that seems to be the best solution. When factory ammo won't work, it becomes s gun issue. With reloads, maybe, maybe not.
User avatar
By earlwb
#14593 it sounds like the headspace is too tight. Yeah you need to get Armscor to check it out. They do make go no go gauges for the .22 TCM, but I don't know if you want to go that route and test the rifle yourself or not. Armscor has been pretty good about getting things fixed though. I would get them to check it out.
http://pacifictoolandgauge.com/imperial ... auges.html
User avatar
By Carolina Shooter
#14859 Finally sent the rifle to Armscor. Returned in 5 weeks. Gunsmith's report said that he replaced the "spacer insert". There is nothing in the parts list which identifies what a spacer insert is. I loaded a magazine with 5 rounds and cycled the bolt. It fed and ejected all 5 with no problem. Haven't been to the range yet (too hot in South Carolina), so, I don't know if the problem has been solved. Will report when it gets cooler. I did purchase some US made ammo, but haven't shot it yet.